Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
题目描述:
推箱子是一个很经典的游戏.今天我们来玩一个简单版本.在一个M*N的房间里有一个箱子和一个搬运工,搬运工的工作就是把箱子推到指定的位置,注意,搬运工只能推箱子而不能拉箱子,因此如果箱子被推到一个角上(如图2)那么箱子就不能再被移动了,如果箱子被推到一面墙上,那么箱子只能沿着墙移动.
现在给定房间的结构,箱子的位置,搬运工的位置和箱子要被推去的位置,请你计算出搬运工至少要推动箱子多少格.
Input
输入数据的第一行是一个整数T(1<=T<=20),代表测试数据的数量.然后是T组测试数据,每组测试数据的第一行是两个正整数M,N(2<=M,N<=7),代表房间的大小,然后是一个M行N列的矩阵,代表房间的布局,其中0代表空的地板,1代表墙,2代表箱子的起始位置,3代表箱子要被推去的位置,4代表搬运工的起始位置.
Output
对于每组测试数据,输出搬运工最少需要推动箱子多少格才能帮箱子推到指定位置,如果不能推到指定位置则输出-1.
Sample Input
1
5 5
0 3 0 0 0
1 0 1 4 0
0 0 1 0 0
1 0 2 0 0
0 0 0 0 0
Sample Output
4
题目链接
http://acm.hdu.edu.cn/showproblem.php?pid=1254
———————————————————————————
问题解析:
对箱子广搜,对人深搜。
也可定义三或四维数组对深搜进行压缩。
废话不多说上代码:
#include <bits/stdc++.h>
using namespace std;
#define lit 50
#define scd(a) scanf("%d", &a)
#define scdd(a,b) scanf("%d%d", &a,&b)
#define scddd(a,b,c) scanf("%d%d%d", &a,&b,&c)
#define rp(i, n) for(int i = 0; (i) < (n); i++)
#define rpl(i, n) for(int i = 1; (i) <= (n); i++)
struct MAN
{
int x;
int y;
int box_x;
int box_y;
int boxstep;
bool friend operator<(MAN a,MAN b)
{
return a.boxstep > b.boxstep;
}
};
int m, n;
int maze[lit][lit];
int dir[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};//注意移动顺序
bool hush[lit][lit][lit][lit];
int bfs(MAN st)
{
memset(hush, false, sizeof hush);
priority_queue<MAN> man;//这里用到了优先队列
MAN now,next;
st.boxstep = 0;
man.push(st);
hush[st.x][st.y][st.box_x][st.box_y] = 1;
while(!man.empty())
{
now = man.top();
man.pop();
if(maze[now.box_x][now.box_y] == 3)
{
return now.boxstep;
}
else
{
for(int i = 0;i <4;i ++)
{
next.x = now.x + dir[i][0];
next.y = now.y + dir[i][1];
next.boxstep = now.boxstep;
next.box_x = now.box_x;
next.box_y = now.box_y;
if(next.x < 1 || next.x > m || next.y < 1 || next.y > n)
continue;
if(maze[next.x][next.y] == 1)
continue;
if(hush[next.x][next.y][now.box_x][now.box_y])
continue;
if(next.x == now.box_x && next.y == now.box_y)
{
next.box_x = now.box_x + dir[i][0];
next.box_y = now.box_y + dir[i][1];
if(maze[next.box_x][next.box_y] == 1)
continue;
if(next.box_x < 1 || next.box_y < 1 || next.box_x >m || next.box_y > n)
continue;
if(hush[next.x][next.y][next.box_x][next.box_y])
continue;
next.boxstep = now.boxstep + 1;
}
hush[next.x][next.y][next.box_x][next.box_y] = 1;
man.push(next);
}
}
}
return -1;
}
int main()
{
int T;
int step;
MAN st;
scd(T);
while(T--)
{
memset(&st, 0, sizeof st);
scdd(m, n);
rpl(i,m)
{
rpl(j,n)
{
scd(maze[i][j]);
if(maze[i][j] == 2)
st.box_x = i,st.box_y = j;
if(maze[i][j] == 4)
st.x = i,st.y = j;
}
}
step = bfs(st);
printf("%d\n", step);
}
return 0;
}
奉上几组数据:
1
4 4
0 0 1 1
0 0 1 1
0 2 3 1
1 4 1 1
答案是3
1
7 4
0 0 0 0
0 0 1 0
0 2 0 3
1 4 1 0
1 0 1 0
1 0 1 0
1 0 0 0
答案是2
1
4 3
0 0 0
0 0 1
0 2 3
1 4 1
答案是3
来源:CSDN
作者:白发公子羽
链接:https://blog.csdn.net/weixin_45675201/article/details/103532818