ALGO48 算法训练 关联矩阵

谁都会走 提交于 2020-03-17 07:40:02

资源限制
时间限制:1.0s 内存限制:512.0MB
问题描述
  有一个n个结点m条边的有向图,请输出他的关联矩阵。
输入格式
  第一行两个整数n、m,表示图中结点和边的数目。n<=100,m<=1000。
  接下来m行,每行两个整数a、b,表示图中有(a,b)边。
  注意图中可能含有重边,但不会有自环。
输出格式
  输出该图的关联矩阵,注意请勿改变边和结点的顺序。
样例输入
5 9
1 2
3 1
1 5
2 5
2 3
2 3
3 2
4 3
5 4
样例输出
1 -1 1 0 0 0 0 0 0
-1 0 0 1 1 1 -1 0 0
0 1 0 0 -1 -1 1 -1 0
0 0 0 0 0 0 0 1 -1
0 0 -1 -1 0 0 0 0 1

import java.util.Scanner;

public class ALGO48 {

	public static void main(String[] args) {
		
		Scanner sc = new Scanner(System.in);
		
		int n = sc.nextInt();
		int m = sc.nextInt();
		int[][] data = new int[m+1][2];
		
		for(int i=1; i<=m; i++) {
			data[i][0] = sc.nextInt();
			data[i][1] = sc.nextInt();
		}
		
		
		int[][] result = new int[n+1][m+1];
		
		for(int i=1; i<=n; i++) {
			
			for(int j=1; j<=m ; j++) {
				if(data[j][0] == i) {
					result[i][j] = 1;
				}else if(data[j][1] == i) {
					result[i][j] = -1;
				}
				if(result[i][j] != -1) {
					System.out.print(" "+result[i][j]+" ");
				}else {
					System.out.print(result[i][j]+" ");
				}
			}
			System.out.println();
			
		}
		
		
	}

}

这题需要注意对其方式,当不是-1时,需要在前面加一个空格来对齐。

易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!