输入一个字符串和一个非负整数N,要求将字符串循环左移N次。
输入格式:
输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。
输出格式:
在一行中输出循环左移N次后的字符串。
输入样例
Hello World!
2
输出样例:
llo World!He
题意就是将开头的第一个字符移动到最后,次数是N;
理解了题意,那么就好解题了
思路:就是将第一个字符提取出来,然后删除,在插入到末尾就OK;
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
string s;
getline(cin,s); //输入已回车结束的字符串
int n;cin>>n;
char ch;
while(n--) //要移动的次数
{
ch=*s.begin(); //因为s.begin() 是迭代器,相当于地址,所以要加'*' 指针
s.erase(s.begin()); //删除迭代器 s.begin() 处的元素,这里是第一个元素
s.push_back(ch); //末尾插入
}
for(string::iterator it=s.begin();it!=s.end();it++) //迭代器输出
cout<<*it;
system("pause");
return 0;
}
可以留下你的小赞赞嘛
来源:CSDN
作者:是谁家的包子呀
链接:https://blog.csdn.net/weixin_45836300/article/details/104347552