PPP:与以太网一样,是数据链路层 协议
https://www.cnblogs.com/jodyccf/p/10458270.html
如果上层为IP协议,NCP就是IPCP协议。
--在POS接口上配置ip
[r3]int p2/0/0
[r3-Pos2/0/0]ip add 200.1.1.2 24
[r3-Pos2/0/0]display this
[V200R003C00]
#
interface Pos2/0/0
link-protocol ppp --配置启动PPP协议
ip address 200.1.1.2 255.255.255.0
#
--修改链路层协议为hdlc
[r3-Pos2/0/0]link-protocol hdlc
[r3-Pos2/0/0]display this
[V200R003C00]
#
interface Pos2/0/0
link-protocol hdlc
ip address 200.1.1.2 255.255.255.0
--查看pos接口详情
[r3]display interface pos2/0/0
Pos2/0/0 current state : UP
Line protocol current state : UP
Last line protocol up time : 2020-01-29 14:46:15 UTC-08:00
Description:HUAWEI, AR Series, Pos2/0/0 Interface
Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)
Internet Address is 200.1.1.2/24
Link layer protocol is PPP
LCP opened, IPCP opened
Last physical up time : 2020-01-29 14:46:03 UTC-08:00
Last physical down time : 2020-01-29 14:41:07 UTC-08:00
Current system time: 2020-01-29 14:46:36-08:00
Last 300 seconds input rate 0 bits/sec 0 packets/sec
Last 300 seconds output rate 0 bits/sec 0 packets/sec
Input: 59 packets, 1902 bytes
Total error: 0, CRC: 0
Giants: 0, Runts: 0
Output: 61 packets, 858 bytes
Total error: 0
Input bandwidth utilization : 0%
Output bandwidth utilization : 0%
--被验证方增加用户名和密码
[r3-Pos2/0/0]ppp pap local-user huawei password cipher hlh
--验证方开启认证功能
[r1-Pos6/0/0]ppp authentication-mode pap
[r1-Pos6/0/0]q
[r1]aaa
[r1-aaa]local-user huawei password cipher hlh
[r1-aaa]local-user hlh service-type ppp
interface dialer 1
ip address ppp-negotiate
ppp pap local-user huawei password cipher hlh
dialer bundle 12
dialer user huawei
dialer bundle 12
pppoe-client dialer-bundle-number 12
interface virtual-template 1
ppp authentication-mode pap
ip pool 1
network 100.1.1.0 mask 24
interface virutal-template 1
remote address pool 1
pppoe-server bind virtual-template 1
ip route-static 0.0.0.0 0.0.0.0 dialer 1
acl 2000
rule 5 permit source 192.168.1.1 0.0.0.0
nat bound 2000
=================
mp-group 0/0/1
ip add 192.168.12.1 24
int s4/0/0
ppp mp mp-group 0/0/1
int s4/0/1
ppp mp mp-group 0/0/1
aaa
local-user huawei password cipher hcie
local-user huawei service-type ppp
interface s4/0/0/0
ppp authentication chap
interface s4/0/0/1
ppp authentication chap
interface s4/0/0/0
ppp chap user huawei password hcie
interface s4/0/0/1
ppp chap user huawei password hcie
来源:CSDN
作者:weixin_42868638
链接:https://blog.csdn.net/weixin_42868638/article/details/104108295