poj 1459 Power Network 【图论-网络流-最大流-EK】

。_饼干妹妹 提交于 2019-11-26 18:25:36
                                Power Network
                Time Limit: 2000MS      Memory Limit: 32768K

Description
A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

figure 1

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题目大意:一个国家电网,总共有n个节点,其中有np个节点是发电站,一些是nc个节点是消耗站,其他的是中转站,还有m条线路,用于连接各个节点,每条线路上规定有最大的电量流动。发电站只产生电量不消耗电量,消耗站只消耗不产能,中转不消耗不产能,请问这个电路中最大的消耗量为多少?

解题思路:刚开始的时候被题中的两个图吓到了,等看懂题意后,感觉很水
虚拟一个源点,让所有的发电站与源点相连
虚拟一个汇点,让所有的消耗站与汇点相连
根据输入数据,把各个节点相连

此题坑点:如果使用scanf()进行读取数据,读取到左括号会报错,应先把左括号以及之前的除数字外的字符,全部清除干净
如果使用cin 只需要挨个读取即可

AC代码:

//EK AC

# include <iostream>
# include <cstdio>
# include <cstring>
# include <string>

using namespace std;

# define MAXN 505
# define INF 1e9 + 100

int map[MAXN][MAXN];
int que[MAXN];
int used[MAXN];
int pre[MAXN];

int min(int a, int b)
{
    return a > b ? b : a;
}

int Bfs(int s, int t)
{
    int head = 1;
    int tail = 1;
    memset(pre, -1, sizeof(pre));
    que[tail++] = s;
    pre[s] = -1;
    while (tail > head)
    {
        int u = que[head++];
        for (int i = 0; i <= t; i++)
        {
            if (pre[i] == -1 && map[u][i] > 0)
            {
                pre[i] = u;
                if (i == t)
                {
                    return 1;
                }
                que[tail++] = i;
            }
        }
    }
    return 0;
}

int Maxflow(int s, int t)
{
    int maxflow = 0;
    while (Bfs(s, t))
    {
        int i;
        int minflow = INF;
        for (i = t; i != s; i = pre[i])
        {
            minflow = min(minflow, map[pre[i]][i]);
        }
        for (i = t; i != s; i = pre[i])
        {
            map[pre[i]][i] -= minflow;
            map[i][pre[i]] += minflow;
        }
        maxflow += minflow;
    }
    return maxflow;
}

int main(void)
{
    int n, np, nc, m;
    while (~scanf("%d %d %d %d", &n, &np, &nc, &m))
    {
        memset(map, 0, sizeof(map));
        int s = 0;
        int t = n + 1;
        int i, j;
        int u, v, w;
        char ch;
        for (i = 1; i <= m; i++)
        {
            while ((ch = getchar()) != '(');//清除左括号以及之前的所有空格

            scanf("%d,%d)%d", &u, &v, &w);
            if (u == v) //这个加不加都无所谓
            {
                continue;
            }
            u++;
            v++;
            map[u][v] = w;
        }

        for (i = 1; i <= np; i++)
        {
            while ((ch = getchar()) != '(');

            scanf("%d)%d", &u, &w);
            u++;
            map[s][u] = w;
        }
        for (i = 1; i <= nc; i++)
        {
            while ((ch = getchar()) != '(');

            scanf("%d)%d", &u, &w);
            u++;
            map[u][t] = w;
        }
        printf("%d\n", Maxflow(s, t));
    }
    return 0;
}

超时算法:但不知道为什么Ford-Fulkerson超时
希望有大神能够指点一下

//Ford-Fulkerson Time Limit 
//不知道为什么超时
# include <iostream>
# include <cstdio>
# include <cstring>
# include <string>

using namespace std;

# define MAXN 505
# define INF 1e9 + 100

int map[MAXN][MAXN];
int used[MAXN];

int min(int a, int b)
{
    return a > b ? b : a;
}

int Dfs(int s, int t, int f)
{
    if (s == t)
    {
        return f;
    }
    for (int i = 0; i <= t; i++)
    {
        if (map[s][i] > 0 && !used[i])
        {
            used[i] = 1;
            int d = Dfs(i, t, min(f, map[s][i]));
            if (d > 0)
            {
                map[s][i] -= d;
                map[i][s] += d;
                return d;
            }
        }
    }
    return 0;
}

int Maxflow(int s, int t)
{
    int maxflow = 0;
    while (1)
    {
        memset(used, 0, sizeof(used));
        int f = Dfs(s, t, INF);
        if (!f)
        {
            return maxflow;
        }
        maxflow += f;
    }
}

int main(void)
{
    int n, np, nc, m;
    while (~scanf("%d %d %d %d", &n, &np, &nc, &m))
    {
        memset(map, 0, sizeof(map));
        int s = 0;
        int t = n + 1;
        int i, j;
        int u, v, w;
        char ch;
        for (i = 1; i <= m; i++)
        {
            while ((ch = getchar()) != '(');

            scanf("%d,%d)%d", &u, &v, &w);
            if (u == v) //去掉自环情况
            {
                continue;
            }
            u++;
            v++;
            map[u][v] = w;
        }

        for (i = 1; i <= np; i++)
        {
            while ((ch = getchar()) != '(');

            scanf("%d)%d", &u, &w);
            u++;
            map[s][u] = w;
        }
        for (i = 1; i <= nc; i++)
        {
            while ((ch = getchar()) != '(');

            scanf("%d)%d", &u, &w);
            u++;
            map[u][t] = w;
        }
        printf("%d\n", Maxflow(s, t));
    }
    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!