题目如下:
Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!
这和前面那个题基本一样,只是多了构建图的这个过程 |
思路:
1.用一个结构体存坐标,即点。另外一个结构体存边,用于表示从i点到j点距离。
2.对后者结构体按照边长从小到大排序。然后从小到大选择边,要边长满足题目要求且不会构成环。
剩下的基本和前面一个题一模一样,最小生成树的模板了。
#include <iostream>
#include <cstdio>
#include <stdio.h>
#include <cstring>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
#include <cstdlib>
#include <math.h>
#include <climits>
#define maxn 10000+500
using namespace std;
static int inf = 0x3f3f3f3f;
int father[maxn];
int n;
int cnt;
typedef struct tree{
int from;
int to;
double val;
}T;
typedef struct pos{
int x;
int y;
}P;
bool cmp(T a, T b){
return a.val<b.val;
}
double dis(int x1, int y1,int x2, int y2 ){
return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void init()
{
for(int i=0;i<n;i++)
father[i] = i;
}
int get(int x)
{
return father[x] = (father[x]==x?x:get(father[x]));
}
bool sametree(T pos)
{
int a = get(pos.from);
int b = get(pos.to);
if(a!=b&&pos.val>=10*100&&pos.val<=1000*100)
{
father[b] = a;
return true ;
}
return false;
}
int main()
{
int kase;
cin>>kase;
while(kase--)
{
cin>>n;
T a[maxn];
P b[maxn];
cnt = 0;
for(int i=0;i<n;i++)
cin>>b[i].x>>b[i].y;
for(int i=0;i<n;i++)
{
for(int j=0;j<i;j++) //构建图
{
a[cnt].from = i;
a[cnt].to = j;
a[cnt].val = dis(b[i].x,b[i].y,b[j].x,b[j].y)*100.0;
cnt++;
}
}
init();
sort(a,a+cnt,cmp);
int num = 1;
double less_cost = 0;
for(int i=0;i<cnt;i++)
{
if(sametree(a[i]))
{
less_cost+=a[i].val;
num++;
}
}
if(num==n)
printf("%.1lf\n",less_cost);
else
cout<<"oh!"<<endl;
}
return 0;
}
来源:CSDN
作者:追风者_
链接:https://blog.csdn.net/qq_45492531/article/details/104518131