用天平找小球
三个球A、B、C,大小形状相同且其中有一个球与其他球重量不同。要求找出这个不一样的球。
输入格式:
输入在一行中给出3个正整数,顺序对应球A、B、C的重量。
输出格式:
在一行中输出唯一的那个不一样的球。
输入样例:
1 1 2
输出样例:
C
C语言
#include<stdio.h>
int main()
{
int A,B,C;
scanf("%d %d %d",&A,&B,&C);
if(A==B&&C!=A)
printf("C");
else if(A==C&&A!=B)
printf("B");
else if(B==C&&B!=A)
printf("A");
return 0;
}
java语言
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int A,B,C;
Scanner reader=new Scanner(System.in);
A=reader.nextInt();
B=reader.nextInt();
C=reader.nextInt();
if(A==B&&C!=A)
System.out.printf("C");
else if(A==C&&A!=B)
System.out.printf("B");
else if(B==C&&B!=A)
System.out.printf("A");
}
}
来源:CSDN
作者:心音子谦
链接:https://blog.csdn.net/weixin_45714844/article/details/104094154