Discription
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260
题意
给定一个N和一个M。
求解在1<=X<=N
的条件下,
使(X,N)>=M
成立的X的个数
思路
设X=k*a
,N=k*b
,k为X和N的公因数;
X成立的个数就是a成立的个数,a<=b;
当k一定时,a成立的个数为小于a且与a互质的数的个数。
枚举k求出在不同的情况下成立的a的个数,累加求和即可
AC代码
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
///直接求解一个数n的欧拉函数
int euler(int n) //返回euler(n)
{
int res=n,a=n;
for(int i=2; i*i<=a; i++)
{
if(a%i==0)
{
res=res/i*(i-1);//先进行除法是为了防止中间数据的溢出
while(a%i==0)
a/=i;
}
}
if(a>1)
res=res/a*(a-1);
return res;
}
int t;
int n,m,ans;
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
ans=0;
for(int i=1;i<=sqrt(n);i++)
{
if(n%i==0)
{
if(i>=m)
ans+=euler(n/i);
if(n/i>=m&&i*i!=n)
ans+=euler(i);
}
}
printf("%d\n",ans);
}
return 0;
}
来源:CSDN
作者:爱吃老谈酸菜的DV
链接:https://blog.csdn.net/weixin_43460224/article/details/103995744