Description
设有n个城市,依次编号为0,1,2,……,n-1(n<=100),另外有一个文件保存n个城市之间的距离(每座城市之间的距离都小于等于1000)。当两城市之间的距离等于-1时,表示这两个城市没有直接连接。求指定城市k到每一个城市i(0<=I,k<=n-1)的最短距离。
Input
第一行有两个整数n和k,中间用空格隔开;以下是一个NxN的矩阵,表示城市间的距离,数据间用空格隔开。
Output
输出指定城市k到各城市间的距离(从第0座城市开始,中间用空格分开)
Sample Input
3 1
0 3 1
3 0 2
1 2 0
Sample Output
3 0 2
这,是一道模板题
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
#include<cstdio>
using namespace std;
long long n,m,q,dis[1000000],hd[100000],tot;
struct node{
int x,y,next,w;
}a[10000001];
int v[100010];
void add(int x,int y,int z){
tot++;
a[tot].x=x;
a[tot].y=y;
a[tot].w=z;
a[tot].next=hd[x];
hd[x]=tot;
}
void spfa(int x){
for(int i=1;i<=n;i++){
dis[i]=2147483647;
v[i]=0;
}
dis[x]=0;
v[x]=1;
queue<int>p;
p.push(x);
while(!p.empty()){
int x1=p.front();p.pop();
for(int j=hd[x1];j;j=a[j].next){
if(dis[a[j].y]>dis[x1]+a[j].w){
dis[a[j].y]=dis[x1]+a[j].w;
if(v[a[j].y]==0){
v[x1]=1;
p.push(a[j].y);
}
}
}
v[x1]=0;
}
}
int main(){
cin>>n>>q;
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
int k;
cin>>k;
if(k==-1)continue;
add(i,j,k);
add(j,i,k);
}
}
spfa(q+1);
for(int i=1;i<=n;i++){
cout<<dis[i]<<' ';
}
}
来源:CSDN
作者:刘子涵ssl
链接:https://blog.csdn.net/liuziha/article/details/103745373