Problem Description
给出四个点,判断这四个点能否构成一个正方形。
Input
输入的第一行包含一个整数T(T≤30)表示数据组数,每组数据只有一行,包括8个整数x1, y1, x2, y2,x3,y3,x4,y4(数据均在-1000,1000 之间)以逆时针顺序给出四个点的坐标。
Output
每组数据输出一行,如果是正方形,则输出: YES, 否则,输出:NO。
Sample Input
2
0 0 1 0 1 1 0 1
-1 0 0 -2 1 0 2 0
Sample Output
YES
NO
import java.util.*;
import java.text.*;
class Square{
int x;
int y;
public Square(int x, int y) {
super();
this.x = x;
this.y = y;
}
public double distance(Square s) {
return Math.pow((x-s.x), 2) + Math.pow((y-s.y), 2);
}
}
public class Main {
public static void main(String[] args) throws ParseException {
Scanner sc = new Scanner(System.in);
int T = sc.nextInt();
while(T-- != 0) {
Square s1 = new Square(sc.nextInt(), sc.nextInt());
Square s2 = new Square(sc.nextInt(), sc.nextInt());
Square s3 = new Square(sc.nextInt(), sc.nextInt());
Square s4 = new Square(sc.nextInt(), sc.nextInt());
if(s1.distance(s2) == s1.distance(s4) && s1.distance(s3) == s2.distance(s4) && s3.distance(s2) == s3.distance(s4)
&& s4.distance(s1) == s4.distance(s3))//逆时针,对角线相等
{
System.out.println("YES");
}
else {
System.out.println("NO");
}
}
sc.close();
}
}
来源:CSDN
作者:sugargx
链接:https://blog.csdn.net/gx17864373822/article/details/79872983