Stone game

会有一股神秘感。 提交于 2019-11-29 17:32:36
  •  31.91%
  •  3000ms
  •  262144K
 

CSL loves stone games. He has nn stones; each has a weight a_iai. CSL wants to get some stones. The rule is that the pile he gets should have a higher or equal total weight than the rest; however if he removes any stone in the pile he gets, the total weight of the pile he gets will be no higher than the rest. It's so easy for CSL, because CSL is a talented stone-gamer, who can win almost every stone game! So he wants to know the number of possible plans. The answer may be large, so you should tell CSL the answer modulo 10^9 + 7109+7.

Formerly, you are given a labelled multiset S=\{a_1,a_2,\ldots,a_n\}S={a1,a2,,an}, find the number of subsets of SS: S'=\{a_{i_1}, a_{i_2}, \ldots, a_{i_k} \}S={ai1,ai2,,aik}, such that

\left(Sum(S') \ge Sum(S-S') \right) \land \left(\forall t \in S', Sum(S') - t \le Sum(S-S') \right) .(Sum(S)Sum(SS))(tS,Sum(S)tSum(SS)).

 

InputFile

The first line an integer TT (1 \leq T \leq 10)1T10), which is the number of cases.

For each test case, the first line is an integer nn(1 \leq n \leq 3001n300), which means the number of stones. The second line are nn space-separated integers a_1,a_2,\ldots,a_na1,a2,,an (1 \leq a_i \leq 5001ai500).

OutputFile

For each case, a line of only one integer tt --- the number of possible plans. If the answer is too large, please output the answer modulo 10^9 + 7109+7.

样例输入

2
3
1 2 2
3
1 2 4

样例输出

2
1

样例解释

In example 1, CSL can choose the stone 1 and 2 or stone 1 and 3. 

 In example 2, CSL can choose the stone 3.

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
const int mod = 1000000007;
const int maxn = 305;

int T, n;
int c[maxn], dp[308][150008];


int main() {
//#ifndef ONLINE_JUDGE
//    freopen("pre.txt", "r", stdin);
//    freopen("1.txt","w",stdout);
//#endif
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &n);
        ll tot = 0, res = 0;
        for (register int i = 1; i <= n; ++i) {
            scanf("%d", &c[i]);
            tot += c[i];
        }
        sort(c + 1, c + 1 + n);
        for (register int i = 0; i <= tot; ++i)dp[n + 1][i] = 0;
        dp[n + 1][0] = 1;
        for (register int i = n; i >= 1; --i) {
            for (register int j = 0; j <= tot; ++j) {
                dp[i][j] = dp[i + 1][j];
                if (j >= c[i]) {
                    dp[i][j] += dp[i + 1][j - c[i]];
                    dp[i][j] %= mod;
                    if (j >= tot - j && c[i] >= j - (tot - j)) {
                        res += dp[i + 1][j - c[i]];
                        res %= mod;
                    }
                }
            }
        }
        printf("%lld\n", res);
    }
    return 0;
}

 

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!