资源限制
时间限制:1.0s 内存限制:512.0MB
问题描述
给定一个长度为n的数列,将这个数列按从小到大的顺序排列。1<=n<=200
输入格式
第一行为一个整数n。
第二行包含n个整数,为待排序的数,每个整数的绝对值小于10000。
输出格式
输出一行,按从小到大的顺序输出排序后的数列。
样例输入
5
8 3 6 4 9
样例输出
3 4 6 8 9
#include<stdio.h>
#define N 200
int *sort(int a[],int n)
{
int i,j;
for(i=1;i<n;i++)
for(j=i+1;j<=n;j++)
{
int temp;
if(a[i]>a[j])
{
temp=a[i];
a[i]=a[j];
a[j]=temp;
}
}
return a;
}
int main()
{
int n,i;
int a[N];
while(~scanf("%d",&n))
{
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
int *b=sort(a,n);
for(i=1;i<=n;i++)
printf("%d ",b[i]);
}
return 0;
}
来源:CSDN
作者:accumulation_mm
链接:https://blog.csdn.net/accumulation_mm/article/details/104295070