大小写转换

我们两清 提交于 2019-12-15 14:31:35

大小写转换

Problem Description

X现在要学习英文以及各种稀奇古怪的字符的了。现在他想把一串字符中的小写字母变成大写字符,大写字母变成小写字母,其他的保持不变。

Input

输入有多组。
每组输入一个字符串,长度不大于80,不包含空格。

Output

输出转换后的字符串

Sample Input

A*
B+

Sample Output

a*
b+

#include <stdio.h>
#include <stdlib.h>

int main()
{
    char s[80];
    char i,n;
    while(gets(s))
    {
        for(i=0;i<strlen(s);i++)
        {
            if((s[i]>='a'&&s[i]<='z'))
            {
                s[i]-=32;
            }
            else if(s[i]>='A'&&s[i]<='Z')
            {
                s[i]+=32;
            }
        }
        printf("%s\n",s);
    }
    return 0;
}
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!