统计字符串中的字符个数。

怎甘沉沦 提交于 2020-03-17 05:55:21

题目内容:

定义函数countchar()按字母表顺序统计字符串中所有出现的字母的个数(允许输入大写字符,并且计数时不区分大小写)。形如:

def countchar(string):
      ... ...
     return a list
if __name__ == "__main__":
     string = input()
     ... ...
     print(countchar(string))

输入格式:

字符串

输出格式:

列表

输入样例:

Hello, World!

输出样例:

[0, 0, 0, 1, 1, 0, 0, 1, 0, 0, 0, 3, 0, 0, 2, 0, 0, 1, 0, 0, 0, 0, 1, 0, 0, 0]

def countChar(s):
    outPut=[0 for i in range(26)]
    for item in s:
        if item.isalpha()!=0:
            index=ord(item.lower())-97
            outPut[index]+=1
    return outPut

string=input()
print(countChar(string))
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!