1086 Tree Traversals Again (25分)

浪子不回头ぞ 提交于 2020-03-08 21:13:03

题目

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N(30)N(\le30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目大意

给出一系列栈的操作,根据出栈入栈过程以及中序遍历结果建立一个树,可以证明这棵树是唯一的,现在要输出这棵树的后序遍历结果。

思路

我们知道建立一棵树单单只靠中序遍历是不行的,所以必须结合栈操作,我们模拟建树过程,会发现这样一个规律;

  1. 前一步操作是Push时,那么这一步Push就是插入左子树;
  2. 前一步操作是Pop时,那么这一步Push就是插入右子树;
    节点值直接用下标表示,这样在找父节点的时候直接下标访问即可,具体代码如下;

代码

#include <iostream>
#include <cstdio>
#include <stack>
#include <vector>
using namespace std;

struct node{
    int left;
    int right;
}node[31];

vector<int> ans;

void postorder(int root){
    if(root == -1)
        return;
    postorder(node[root].left);
    postorder(node[root].right);
    ans.push_back(root);
}

int main(){
    int n, p, root;
    stack<int> sta;
    char op[5];
    scanf("%d", &n);
    for(int i=1; i<=n; i++)
        node[i].left = -1, node[i].right = -1;
    int d = 0, o = 0;
    for(int i=0; i<2*n; i++){
        scanf("%s", op);
        if(op[1] == 'u'){
            scanf("%d", &p);
            sta.push(p);
            if(d == 0)
                root = p;
            else{
                if(o == 0)
                    node[d].left = p;
                else
                    node[d].right = p;
            }
            d = p, o = 0;
        }
        else{
            d = sta.top();
            o = 1;
            sta.pop();
        }
    }
    postorder(root);
    for(int i=0; i<ans.size(); i++){
        if(i)
            printf(" ");
        printf("%d", ans[i]);
    }
    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!