目录
1,题目描述
Sample Input:
3 2 3 1
Sample Output:
41
一个电梯根据特定的楼层进行上下,计算总时间。
输入:
上下总数:N;其余:具体楼层
输出:
总用时
2,思路
签到题,就不多说了吧。。。
3,代码
#include<iostream>
using namespace std;
int main(){
int n;
cin>>n;
int now = 0, last = 0;
int time = 0;
for(int i = 0; i < n; i++){
cin>>now;
if(last > now){
time += (last - now) * 4 + 5;
last = now;
}else{
time += (now - last) * 6 + 5;
last = now;
}
}
cout<<time;
return 0;
}
来源:CSDN
作者:&再见萤火虫&
链接:https://blog.csdn.net/qq_41528502/article/details/104205919