Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
思路:就是有一个背包,尽可能的往里面放东西。注意的是先价值后体积
#include<iostream>
#include<stdio.h>
#include<string>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[1005];
int w[1005];
int v[1005];
int main() {
int T;
scanf("%d", &T);
while (T--)
{
int N, V;
scanf("%d %d", &N, &V);
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= N; i++) {
scanf("%d", &v[i]);
}
for (int i = 1; i <= N; i++) {
scanf("%d", &w[i]);
}
for (int i = 1; i <= N; i++) {
for (int j = V; j >= w[i]; j--) {
dp[j] = max(dp[j], dp[j - w[i]] + v[i]);
}
}
printf("%d\n", dp[V]);
}
return 0;
}
来源:CSDN
作者:实在不知道什么
链接:https://blog.csdn.net/weixin_43813718/article/details/104144998