题目描述
给出一串字符,要求统计出里面的字母、数字、空格以及其他字符的个数。
字母:A, B, …, Z、a, b, …, z组成
数字:0, 1, …, 9
空格:" "(不包括引号)
剩下的可打印字符全为其他字符。
输入
测试数据有多组。
每组数据为一行(长度不超过100000)。
数据至文件结束(EOF)为止。
输出
每组输入对应一行输出。
包括四个整数a b c d,分别代表字母、数字、空格和其他字符的个数。
样例输入 Copy
A0 ,
ab12 4$
样例输出 Copy
1 1 1 1
2 3 1 1
来源/分类`import java.util.*;
public class Main {
public static void main (String[] args) {
Scanner in= new Scanner (System.in);
while(in.hasNext()) {
String s1=in.nextLine();
int a=0,c=0,d=0,e=0;
char b[]=s1.toCharArray();
for(int i=0;i<s1.length();i++) {
if((b[i]<=‘z’&&b[i]>=‘a’)||(b[i]<=‘Z’&&b[i]>=‘A’))
a++;
else if(b[i]<=‘9’&&b[i]>=‘0’)
c++;
else if(b[i]==’ ')
d++;
else
e++;
}
System.out.println(a+" “+c+” “+d+” "+e);
}
}
}
`
来源:CSDN
作者:尘~容
链接:https://blog.csdn.net/C1hacker/article/details/104135775