【题目描述】
假设表达式中允许包含两种括号:圆括号和方括号,其嵌套的顺序随意,如([ ]())或[([ ][ ])]等为正确的匹配,[( ])或([ ]( )或 ( ( ) ) )均为错误的匹配。
现在的问题是,要求检验一个给定表达式中的括弧是否正确匹配?
输入一个只包含圆括号和方括号的字符串,判断字符串中的括号是否匹配,匹配就输出 “OK” ,不匹配就输出“Wrong”。输入一个字符串:[([][])],输出:OK。
【输入】
输入仅一行字符(字符个数小于255)。
【输出】
匹配就输出 “OK” ,不匹配就输出“Wrong”。
【输入样例】
[(])
【输出样例】
Wrong
#if(1)
#include <iostream>
using namespace std;
int i,j;
#define A 260+5
#include <algorithm>
#include <stack>
#include <stdio.h>
#include <cstring>
int main()
{
char ch[A];
gets(ch);
stack <char>str;
int len=strlen(ch);
for(i=0;i<len;i++)
{
if(ch[i]=='(')
{
str.push(ch[i]);
}
else if(ch[i]==')')
{
if(!str.empty())
{
if(str.top()=='(')
{
str.pop();
}
else
{
cout<<"Wrong"<<endl;
return 0;
}
}
else
{
cout<<"Wrong"<<endl;
return 0;
}
}
if(ch[i]=='[')
{
str.push('[');
}
else if(ch[i]==']')
{
if(!str.empty())
{
if(str.top()=='[')
{
str.pop();
}
else
{
cout<<"Wrong"<<endl;
return 0;
}
}
else
{
cout<<"Wrong"<<endl;
return 0;
}
}
}
if(str.empty())
cout<<"OK"<<endl;
else
cout<<"Wrong"<<endl;
return 0;
}
#endif
来源:CSDN
作者:C_Dreamy
链接:https://blog.csdn.net/C_Dreamy/article/details/103653993