Haskell module naming conventions
How should I name my Haskell modules for a program, not a library , and organize them in a hierarchy ? I'm making a ray tracer called Luminosity. First I had these modules: Vector Colour Intersect Trace Render Parse Export Each module was fine on it's own, but I felt like this lacked organization. First, I put every module under Luminosity , so for example Vector was now Luminosity.Vector (I assume this is standard for a haskell program?). Then I thought: Vector and Colour are independent and could be reused, so they should be separated. But they're way too small to turn into libraries. Where