给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174
,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767
开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,104) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000
;否则将计算的每一步在一行内输出,直到 6174
作为差出现,输出格式见样例。注意每个数字按 4
位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
注意 : 比如输入 不足4位数(1,2,3 ...) , 需要补0 这种情况.
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
using namespace std ;
const int MAX = 1005 ;
typedef long long LL;
int a[10] ;
bool cmp(const int &x , const int &y) {
return x >y ;
}
int asc_desc(int x ,bool flag ) {
memset(a,0,sizeof(a)) ;
int cnt = 4 ;
int p = 1 ;
int sum = 0 ;
for(int i = 0 ; i<4 ;i++ ) {
a[i] = x%10 ;
x/=10 ;
}
if(flag)
sort(a,a+cnt,cmp);
else
sort(a,a+cnt) ;
for(int i = 3 ; i>=0 ; i-- ) {
sum+=(a[i]*p) ;
p*=10 ;
}
return sum ;
}
int main(){
int n ;
cin >> n ;
while(1){
int x = asc_desc(n,true) ;
int y = asc_desc(n,false) ;
int m = x - y ;
printf("%04d - %04d = %04d\n",x,y,m);
if(m == 0 ) break ;
if(m == 6174) break ;
n = m ;
}
return 0 ;
}
来源:https://blog.csdn.net/qq_41661809/article/details/98779574