图论 - PAT甲级 1013 Battle Over Cities C++

纵饮孤独 提交于 2019-11-29 16:41:39

PAT甲级 1013 Battle Over Cities C++

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

附上柳神博客:
https://www.liuchuo.net/

题目大意:

给出n个城市之间有相互连接的m条道路,当删除一个城市和其连接的道路的时候,问其他几个剩余的城市至少要添加多少个路线才能让它们重新变为连通图

分析

添加的最少的路线,就是他们的连通分量数-1,因为当a个互相分立的连通分量需要变为连通图的时候,只需要添加a-1个路线,就能让他们相连。所以这道题就是求去除了某个结点之后其他的图所拥有的连通分量数
使用邻接矩阵存储,对于每一个被占领的城市,去除这个城市结点,就是把它标记为已经访问过,这样在深度优先遍历的时候,对于所有未访问的结点进行遍历,就能求到所有的连通分量的个数~记得因为有很多个要判断的数据,每一次输入被占领的城市之前要把visit数组置为false~~

代码如下:

#include <iostream>
#include <algorithm>

using namespace std;
int v[1001][1001];
bool vis[1001];
int n;
//寻找一条路径从 关注的城市的路径
// v[i][j] 表示图上有一条从 i -> j 的通路
void dfs(int node)
{
    vis[node] = 1;
    for (int i = 1; i <= n; i++)
    {
        if (vis[i] == 0 && v[node][i] == 1)
            dfs(i);
    }
}
int main()
{
    int m, k, a, b;
    cin >> n >> m >> k;
    for (int i = 0; i < m; i++)
    {
        cin >> a >> b;
        v[a][b] = v[b][a] = 1;
    }
    //输入 k 个我们关注的城市 
    //从该城市触发寻找路径(统计连通分量个数)
    //因为城市是无向图
    for (int i = 0; i < k; i++)
    {
        fill(vis, vis + 1001, false);
        cin >> a;
        int cnt = 0;//统计每个城市所连接在的连通分量的个数
        vis[a] = 1; 
        for (int j = 1; j <= n; j++)
        {
            if (vis[j] == 0)
            {
                dfs(j);
                cnt++;
            }
        }
        cout << cnt - 1 << endl;
    }
    system("pause");
    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!