最长公共子序列

断了今生、忘了曾经 提交于 2019-11-29 12:32:27
//poj  1458
Common Subsequence
Time Limit: 1000MS        Memory Limit: 10000K
Total Submissions: 69884        Accepted: 29304
Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp
Sample Output

4
2
0

 

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define N 1000
char s[N],p[N];
int ls,lp,dp[N][N];
//dp[i][j] :s[0]~s[i-1]与p[0]~p[j-1]的最长公共子序列长度
int main()
{
    while(~scanf("%s%s",&s,&p)){
        ls=strlen(s);lp=strlen(p);
        memset(dp,0,sizeof(dp));
        for(int i =1;i<=ls;i++){
            for(int j=1;j<=lp;j++){
                if(s[i-1]==p[j-1]){
                    dp[i][j] = dp[i-1][j-1]+1;
                }
                else{
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[ls][lp]);
    }
    return 0;
 } 

 

易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!