The Dole Queue (双向约瑟夫环)

妖精的绣舞 提交于 2019-11-28 19:48:40

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter- clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

新成立的国家绿色劳工犀牛党(National Green Labour Rhinoceros Party)在认真尝试缩减(减少)领取失业救济金的队伍时,决定了以下战略。每天,所有申请领取失业救济金的人都会围成一个大圈,面朝内。任意选择一个人作为数字1,其余的人按逆时针方向编号,直到N(他将站在1的左边)。从1开始逆时针移动,一个劳工官员对第K个申请人进行计数,另一个劳工官员从N开始顺时针移动,对第M个申请人进行计数。两个被选中的人将被送走接受再培训;如果两个官员都选择同一个人,她(他)将被送走成为一名政治家。然后,每个官员开始在下一个可用的人处重新计数,这个过程将继续进行,直到没有人离开。请注意,两名受害者(抱歉,受训者)会同时离开圆圈,因此一名官员可以统计另一名官员已经选择的人员。(百度翻译)

 

Input

Write a program that will successively read in (in that order) the three numbers (N , k and m; k, m > 0,0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter- clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Note: The symbol ⊔ in the Sample Output below represents a space.

 

Sample Input

10 4 3

0 0 0

Sample Output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7

 

【代码】

#include <iostream>
#include <stdio.h>
#include <string.h>
int peo[30],n;
int go(int post,int d,int step)
{
    int cnt=0;
    while(cnt!=step)
    {
        post=(post+d+n)%n;
        if(peo[post]!=0)
            cnt++;
    }
    return post;
}
int main()
{
    int k,m;
    while(scanf("%d%d%d",&n,&k,&m)&&n&&k&&m)
    {
        memset(peo,0,sizeof(peo));
        int p1=n-1,p2=0,left=n;
        for(int i=0;i<n;i++)
            peo[i]=i+1;
        while(left)
        {
            p1=go(p1,1,k);
            p2=go(p2,-1,m);
            left--;
            printf("%3d",peo[p1]);
            if(p1!=p2)
            {
                printf("%3d",peo[p2]);
                left--;
            }
            if(left)
            {
                printf(",");
            }
            peo[p1]=peo[p2]=0;
        }
        printf("\n");
    }
}

 

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!