1. 输出低于班级平均分的学生信息
【问题描述】
输入N个学生的姓名和语文、数学的得分,求平均分低于班级平均分的学生,将其信息全部输出。分数相同的按输入先后输出。
输入格式:第1行,有一个整数N,N的范围是[1…100];下面有N行,每行一个姓名(字符串),2个整数。姓名由不超过10个的小写字母组成,整数范围是[0…100]。
输出格式:平均分低于班级平均分的学生信息。格式:姓名 语文 数学 平均分。每个学生占一行。如果没有,输出none。
【样例输入】
4
gaoxiang 78 96
wangxi 70 99
liujia 90 87
zhangjin 78 73
【样例输出】
zhangjin 78 73 75.5
#include<iostream>
#include<string>
using namespace std;
struct student {
string name;
int chinese,math;
double avg;
};
student stu[101];
double total = 0;
int main() {
int n;
cin >> n;
for(int i=0; i<n; i++) {
cin >> stu[i].name >> stu[i].chinese >> stu[i].math;
stu[i].avg = (stu[i].chinese + stu[i].math)/2.0;
total = total + stu[i].chinese + stu[i].math;
}
double classAvg = total / (n*2);
bool flag = false;
for(int i=0; i<n; i++) {
if(stu[i].avg < classAvg) {
cout << stu[i].name << " "<<stu[i].chinese << " "<< stu[i].math << " "<< stu[i].avg<<endl;
flag = true;
}
}
if(flag == false){
cout << "none"<<endl;
}
return 0;
}
2. 谁拿了最多奖学金
【问题描述】
某校的惯例是在每学期的期末考试之后发放奖学金。发放的奖学金共有五种,获取的条件各自不同:
1)院士奖学金,每人8000元,期末平均成绩高于80分(>80),并且在本学期内发表1篇或1篇以上论文的学生均可获得;
2)五四奖学金,每人4000元,期末平均成绩高于85分(>85),并且班级评议成绩高于80分(>80)的学生均可获得;
3)成绩优秀奖,每人2000元,期末平均成绩高于90分(>90)的学生均可获得;
4)西部奖学金,每人1000元,期末平均成绩高于85分(>85)的西部省份学生均可获得;
5)班级贡献奖,每人850元,班级评议成绩高于80分(>80)的学生干部均可获得;
只要符合条件就可以得奖,每项奖学金的获奖人数没有限制,每名学生也可以同时获得多项奖学金。例如姚林的期末平均成绩是87分,班级评议成绩82分,同时他还是一位学生干部,那么他可以同时获得五四奖学金和班级贡献奖,奖金总数是4850元。
现在给出若干学生的相关数据,请计算哪些同学获得的奖金总数最高(假设总有同学能满足获得奖学金的条件)。
输入
第一行是一个整数N(1 <= N <= 100),表示学生的总数。接下来的N行每行是一位学生的数据,从左向右依次是姓名,期末平均成绩,班级评议成绩,是否是学生干部,是否是西部省份学生,以及发表的论文数。姓名是由大小写英文字母组成的长度不超过20的字符串(不含空格);期末平均成绩和班级评议成绩都是0到100之间的整数(包括0和100);是否是学生干部和是否是西部省份学生分别用一个字符表示,Y表示是,N表示不是;发表的论文数是0到10的整数(包括0和10)。每两个相邻数据项之间用一个空格分隔。
输出
包括三行,第一行是获得最多奖金的学生的姓名,第二行是这名学生获得的奖金总数。如果有两位或两位以上的学生获得的奖金最多,输出他们之中在输入文件中出现最早的学生的姓名。第三行是这N个学生获得的奖学金的总数。
【样例输入】
4
YaoLin 87 82 Y N 0
ChenRuiyi 88 78 N Y 1
LiXin 92 88 N N 0
ZhangQin 83 87 Y N 1
【样例输出】
ChenRuiyi
9000
28700
#include<iostream>
#include<algorithm>
using namespace std;
struct student {
string name;
int avg,classgrade,paper,total,m;
char gb,xb;
};
student stu[101];
bool comp(student a,student b) {
return a.total > b.total;
}
int main(){
int n,sum=0;
cin >> n;
for(int i=0; i<n; i++) {
stu[i].total = 0;
cin >>stu[i].name >> stu[i].avg >> stu[i].classgrade>>stu[i].gb
>> stu[i].xb >> stu[i].paper;
if(stu[i].avg>80 && stu[i].paper >= 1) {
stu[i].total += 8000;
}
if(stu[i].avg>85 && stu[i].classgrade>80 ) {
stu[i].total +=4000;
}
if(stu[i].avg>90) {
stu[i].total +=2000;
}
if(stu[i].avg>85 && stu[i].xb=='Y' ) {
stu[i].total +=1000;
}
if(stu[i].avg>80 && stu[i].gb=='Y') {
stu[i].total += 850;
}
sum += stu[i].total;
}
//
sort(stu,stu+n,comp);
cout << stu[0].name << endl;
cout << stu[0].total <<endl;
cout << sum <<endl;
return 0;
}
1. 窗口重叠
【问题描述】
窗口重叠。在Windows操作系统中,最主要的桌面元素是窗口。通常一个窗口有4个整数定义位置:左边坐标(left)、右边坐标(right)、上边坐标(top)、下边坐标(bottom)。
现在给你两个窗口位置信息,判断它们位置是否有重叠。
输入格式:共2行,每行四个整数,表示一个窗口的位置信息。
输出格式:如果两个窗口位置重叠,输出重叠的面积;否则输出0。
【样例输入】
10 100 20 60
60 160 50 200
【样例输出】
400
#include<iostream>
#include<string>
using namespace std;
struct Window {
int left,right,top,bottom;
};
Window WinA,WinB,temp;
//定义一个函数输入窗口变量
Window inDate() {
Window temp;
cin >> temp.left >> temp.right >> temp.top >> temp.bottom;
return temp;
}
int main() {
WinA = inDate();
WinB = inDate();
//判断计算重叠窗口temp
temp.left = max(WinA.left,WinB.left);
temp.right = min(WinA.right,WinB.right);
temp.top = max(WinA.top,WinB.top);
temp.bottom = min(WinA.bottom,WinB.bottom);
int s = (temp.right - temp.left)*(temp.bottom - temp.top );
if((temp.right<=temp.left)||(temp.bottom <= temp.top)) {
s = 0;
}
cout << s << endl;
return 0;
}
2. 第K名
【问题描述】
刚举行的万米长跑活动中,有N个人跑完了全程,所用的时间都不相同。颁奖时为了增加趣味性,随机抽了一个数K,要奖励第K名一双跑鞋。
现在组委会给你N个人的姓名、成绩(用时,单位是秒),请你编程快速输出第K名的姓名。
输入
第一行:2个整数N和K,范围(1≤ K ≤ N ≤ 100)。
下面N行:每行第1个是字符串表示姓名;第2个是个整数,表示这个人跑完的使用时间。
输出
一行,第K名的姓名。
【样例输入】
5 3
wangxi 2306
xiaoming 3013
zhangfan 3189
chengli 4012
jiangbou 2601
【样例输出】
xiaoming
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
struct competition{
string name;
int time;
};
competition pep[101];
bool comp(competition a,competition b){
return a.time < b.time;
}
int main() {
int n,k;
cin >> n >> k;
for(int i=0;i<n;i++){
cin >> pep[i].name >> pep[i].time;
}
sort(pep,pep+n,comp);
for(int i=0;i<n;i++){
if(i==k-1){
cout << pep[i].name;
}
}
return 0;
}
来源:oschina
链接:https://my.oschina.net/u/4270037/blog/3649194