poj 1953 World Cup Noise

北城以北 提交于 2020-12-14 05:54:15

World Cup Noise
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 14753
Accepted: 7302

Description

Background
"KO-RE-A, KO-RE-A" shout 54.000 happy football fans after their team has reached the semifinals of the FIFA World Cup in their home country. But although their excitement is real, the Korean people are still very organized by nature. For example, they have organized huge trumpets (that sound like blowing a ship's horn) to support their team playing on the field. The fans want to keep the level of noise constant throughout the match.
The trumpets are operated by compressed gas. However, if you blow the trumpet for 2 seconds without stopping it will break. So when the trumpet makes noise, everything is okay, but in a pause of the trumpet,the fans must chant "KO-RE-A"!
Before the match, a group of fans gathers and decides on a chanting pattern. The pattern is a sequence of 0's and 1's which is interpreted in the following way: If the pattern shows a 1, the trumpet is blown. If it shows a 0, the fans chant "KO-RE-A". To ensure that the trumpet will not break, the pattern is not allowed to have two consecutive 1's in it.
Problem
Given a positive integer n, determine the number of different chanting patterns of this length, i.e., determine the number of n-bit sequences that contain no adjacent 1's. For example, for n = 3 the answer is 5 (sequences 000, 001, 010, 100, 101 are acceptable while 011, 110, 111 are not).

Input

The first line contains the number of scenarios.
For each scenario, you are given a single positive integer less than 45 on a line by itself.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the number of n-bit sequences which have no adjacent 1's. Terminate the output for the scenario with a blank line.

Sample Input

2
3
1

Sample Output

Scenario #1:
5

Scenario #2:
2

Source

TUD Programming Contest 2002, Darmstadt, Germany

[Submit]   [Go Back]   [Status]   [Discuss]

水题无注释

/*=============================================================================
#     FileName: World_Cup_Noise.cpp
#         Desc: 
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-11-26
#   LastChange: 2013-11-26 23:56:58
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>

#define maxn 50

int main()
{
	int case_num = 0;
	scanf("%d", &case_num);

	int dp0[maxn] = {0}, dp1[maxn] = {0};
	memset(dp0, 0, sizeof(dp0));
	memset(dp1, 0, sizeof(dp1));
	dp0[0] = 1;
	dp1[1] = 1;
	for (int i = 1; i < maxn; ++i)
	{
		dp0[i] = dp0[i - 1] + dp1[i - 1];
		dp1[i] = dp0[i - 1];
	}

	int n = 0;
	for (int i = 0; i < case_num; ++i)
	{
		scanf ("%d", &n);
		printf ("Scenario #%d:\n%d\n\n", i + 1, dp0[n] + dp1[n]);
	}
	return 0;
}




标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!