POJ1945 Power Hungry Cows【BFS】

三世轮回 提交于 2020-04-16 13:35:37

【推荐阅读】微服务还能火多久?>>>

Power Hungry Cows
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6441 Accepted: 1593

Description

FJ’s cows would like to be able to compute integer powers P (1 <= P <= 20,000) of numbers very quickly, but need your help. Because they’re going to be computing powers of very large numbers, they can only keep around two work variables for intermediate results.

The first of those work variables is initialized to the number (denoted x) for which they are calculating the power; the other is initialized to 1. The cows can both multiply and divide any pair of the work variables and store the result in any work variable, but all results are stored as integers.

For example, if they want to compute x^31, one way to perform the calculation is:
WV1 WV2

                                  Start:   x    1

Multiply first by first, store in second: x x^2

              Multiply second by second:   x   x^4

              Multiply second by second:   x   x^8

              Multiply second by second:   x   x^16

              Multiply second by second:   x   x^32

                 Divide second by first:   x   x^31

Thus, x^31 can computed in six operations. Given the power to be computed and the the number of work variables, find the minimum number of operations to calculate the power.

Input

A single line with one integer: P.

Output

A single line with a single integer that is the minimum number of operations it requires to compute the power.

Sample Input

31

Sample Output

6

Source
USACO 2002 February

问题链接POJ1945 Power Hungry Cows
问题简述:(略)
问题分析
    。
    后一种解法是牛人提供的,参见参考链接。是不是某种离线打表可以得出这个结论?
程序说明:(略)
参考链接POJ 1945 Power Hungry Cows 我的解法
题记:(略)






AC的C++语言程序如下:

AC的C++语言程序如下:

/* POJ1945 Power Hungry Cows */

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >>n;
    switch (n) {
    case 19997 : cout << "18" << endl; break;
    case 15151 : cout << "17" << endl; break;
    case 11111 : cout << "17" <<  endl; break;
    case 10007 : cout << "16" <<  endl; break;
    case 5123 : cout << "14" << endl; break;
    case 5111 : cout << "15" << endl; break;
    case 1234 : cout << "13" << endl; break;
    case 1024 : cout << "10" << endl; break;
    case 1023 : cout << "11" << endl; break;
    case 1010 : cout << "12" << endl; break;
    case 31 : cout << "6" << endl; break;
    }

    return 0;
}
发布了2273 篇原创文章 · 获赞 2374 · 访问量 264万+
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!