Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
int book[1001],a[1001];
int main()
{
int m,n,k,count1=0,i,j,t,q,count2=0;
scanf("%d%d%d",&m,&n,&k);
while(k--)
{
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(i=0;i<n-1;i++)
{
if(a[i]>a[i+1])
{
for(q=1;q<a[i];q++)
{
if(!book[q])
count2++;
}
if(count2>=m)
{
count1=1;
break;
}
for(j=a[i]-1;j>a[i+1];j--)
{
if(!book[j])
{
count1=1;
break;
}
}
book[a[i]]=1;
count2=0;
}
else
{
for(q=1;q<a[i];q++)
{
if(!book[q])
count2++;
}
for(j=a[i]+1;j<a[i+1];j++)
{
if(!book[j])
{
count2++;
}
}
if(count2>=m)
{
count1=1;
break;
}
book[a[i]]=1;
count2=0;
}
}
if(!count1)
printf("YES\n");
else
printf("NO\n");
count1=0;
count2=0;
memset(book,0,sizeof(book));
}
return 0;
}
来源:CSDN
作者:poptox
链接:https://blog.csdn.net/qq_41514794/article/details/82942993