A - Max Sum Plus Plus(动态规划)本人新手菜鸟勿进,欢迎大神指点✌✌✌

╄→尐↘猪︶ㄣ 提交于 2020-02-16 11:53:20

A - Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. _
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.

从题目中分析:::从题中提取的有效信息是“将n个数分成m组,m组的和加起来得到最大值并输出。”
解题方式:::使用状态dp[i][j]表示前j个数分成i组的最大值
算法解析:::dp[i][j]=max(dp[i][j-1]+a[j],max(dp[i-1][k])+a[j])(0<k<j)
在这里由dp[i][j-1]+a[j]表示前j-1分成i组,第j个必须放在前一组里面。

这篇是我作为新手参考别的博主加上我自己的理解希望不要误导新手

进入正文:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e6+10;
const int INF = 0x3f3f3f3f;//定义无穷大
int a[maxn];//用来存输入数据
int dp[maxn];//储存分的组
int Max[maxn];//max(dp[i-1][k])就是上一组0~j-1的最大值
int main()
{
    int n,m,mmax;
    while(~scanf("%d%d",&m,&n))
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        memset(Max,0,sizeof(Max));//将数据初始化
        for(int i = 1; i <= m; i++)
        {//进行分组
            mmax = -INF;
            for(int j = i; j <= n; j++)
            {//前j个数分成i组至少i个
                dp[j] = max(dp[j-1]+a[j],Max[j-1]+a[j]         
                 //Max[j-1]目前代表的是分成i-1组前j-1个数的最大值,a[j]单独一组组成i组
                //dp[j-1]代表j-1个数分成组,第j个数a[j]放在前面i组的一组中,两种方式选取较大   
                Max[j-1] = mmax;//当前考虑的是j但是mmax是上一次循环得到的,所以更新的是j-1

                mmax = max(mmax,dp[j]);//更新mmax,这样下次循环同样更新的是j-1
            }
            
                    }
        printf("%d\n",mmax);
    }
    return 0;
}
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!