7-27 QQ Account Management (25分)

╄→尐↘猪︶ㄣ 提交于 2020-02-05 22:26:43

You are supposed to implement the functions of account "Log in" and "Register" for the most popular instant messager QQ. The most challenging part is that QQ now has more than a billion users.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (≤) - the total number of queries. Then N lines follow, each contains a query in the format Command QQ_No Password where Command is either R (meaning to register a new account, and hence followed by a new account number and a password), or L (meaning to log in with an existing account, and hence followed by the account number and the password); QQ_No is an integer that is greater than 1000 and no more than 10 digits long; and Password is a string with no less than 6 and no more than 16 characters without any space.

Output Specification:

For each test case, print the corresponding message for each query in a line. The messages are:

  • If a new account is successfully registered, output "Register Successful";
  • If the new registering account number already exists, output "ERROR: Account Number Already Exists";
  • If log in successfully, output "Log in Successful";
  • If the log in account does not exist, output "ERROR: Account Not Exist";
  • If log in with a wrong password, output "ERROR: Wrong Password".

Sample Input:

5
L 1234567890 myQQ@qq.com
R 1234567890 myQQ@qq.com
R 1234567890 myQQ@qq.com
L 1234567890 myQQ@qq
L 1234567890 myQQ@qq.com
 

Sample Output:

ERROR: Account Not Exist
Register Successful
ERROR: Account Number Already Exists
ERROR: Wrong Password
Log in Successful用c++的map代码:
#include <cstdio>
#include <map>
using namespace std;
map<string,string> mp;
int main() {
    int n;
    char op[2],no[11],pw[17];
    scanf("%d",&n);
    for(int i = 0;i < n;i ++) {
        scanf("%s%s%s",op,no,pw);
        if(op[0] == 'R') {
            if(mp[no] != "") printf("ERROR: Account Number Already Exists\n");
            else {
                mp[no] = pw;
                printf("Register Successful\n");
            }
        }
        else {
            if(mp[no] == "") printf("ERROR: Account Not Exist\n");
            else if(mp[no] != pw) printf("ERROR: Wrong Password\n");
            else printf("Log in Successful\n");
        }
    }
    return 0;
}

 

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!