HDU 1241 Oil Deposits

醉酒当歌 提交于 2020-02-05 03:34:47

hdoj 1241 Oil Deposits

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or `@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output
0
1
2
2

Source
Mid-Central USA 1997

题目链接

题目大意:
上下左右,左上左下,右上右下,任意方向相邻的@为同一个集合,问给定图有多少个集合

题目思路:
每次BFS或DFS可访问一个@及相邻的所有@(一个集合),并将它们标记为已访问。看所有@被访问完需要多少次搜索,即有多少个集合

以BFS举例:从任意的一个@开始BFS,搜索到一个@就把它设置为*,直至此次BFS结束,集合的数量加1;再从剩余的@中进行BFS,同样操作至结束,集合数量加1;当图中不存在@时,集合数量即为所求。

下方是BFS代码,也可用DFS做,例如POJ2326这篇博客,采用DFS做

bfs代码:

#include<iostream>
#include<queue>
#include<string>
using namespace std;
int m, n;
int step[8][2] = { {1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,-1},{1,-1},{-1,1} };
const int INF = 1e5;
int grid[105][105];
void bfs(int x, int y)
{
	queue<pair<int, int>> q;
	grid[x][y] = 0;
	q.push(pair<int, int>(x, y));
	while (!q.empty())
	{
		pair<int, int> t = q.front();
		q.pop();
		for (int i = 0; i < 9; i++)
		{
			int a = t.first, b = t.second;
			a += step[i][0], b += step[i][1];
			if (a>=0 && a<m && b>=0 &&b<n &&grid[a][b] ) {
				grid[a][b] = 0;
				q.push(pair<int, int>(a, b));
			}
		}
	}
}
int main()
{
	while (cin >> m >> n, m)
	{
		for (int i = 0; i < m; i++)
		{
			string s;
			cin >> s;
			for (int j = 0; j < n; j++)
			{
				if(s[j]=='@')grid[i][j] = 1;
				else grid[i][j] = 0;
			}
		}
		int cnt = 0;
		for (int i = 0; i < m; i++)
		{
			for (int j = 0; j < n; j++)
			{
				if (grid[i][j]) {
					bfs(i, j);
					cnt++;
				}
			}
		}
		cout << cnt << endl;
	}
	return 0;
}

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!