Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
Sample Output
5
11
给你N个物品和M单位的金钱,每个物品有价格a、购买的前提资金b、价值c,要买某个物品,你的钱必须大于等于b,求出最大能获得的价值量
用前提资金-价格,从小到大排序(选尽可能装进去),在01背包即可
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
using namespace std;
struct node
{
const bool operator<(const node&rhs)const {
return m < rhs.m;
}
int p, q, v;
int m;
};
node s[5050];
int dp[5050];
int main() {
int N, M;
while (scanf("%d %d", &N, &M) != EOF) {
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= N; i++) {
scanf("%d %d %d", &s[i].p, &s[i].q, &s[i].v);
s[i].m = s[i].q - s[i].p;
}
sort(s, s + N);
for (int i = 1; i <= N; i++) {
for (int j = M; j >= s[i].p; j--) {
if (j >= s[i].q) {
dp[j] = max(dp[j], dp[j - s[i].p] + s[i].v);
}
}
}
printf("%d\n", dp[M]);
}
return 0;
}
来源:CSDN
作者:实在不知道什么
链接:https://blog.csdn.net/weixin_43813718/article/details/104144578