算法题 最短路径-02-Frogger

三世轮回 提交于 2020-02-02 09:24:57

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

思路:这里是找从1结点到2结点最远的一条路径,在这条路径中最小的一条边。用floyed算法

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>
#include<map>
#include<iostream>
#include<math.h>
double s;
double a[205][205],d[205][2];
int book[205];
using namespace std;
double distance(double x1, double x2, double y1, double y2) {
	double res;
	res = (x1 - x2)*(x1 - x2) + (y1 - y2)*(y1 - y2);
	return sqrt(res);
}
int main() {
	int n,i,j,k,v=1;
	while (scanf("%d", &n) != EOF) {
		if (n == 0) {
			break;
		}
		for (i = 1; i <= n; i++) {
			scanf("%lf %lf", &d[i][0], &d[i][1]);
		}
		for (i = 1; i <= n; i++) {
			for (j = 1; j <= n; j++) {
                s = distance(d[i][0], d[j][0], d[i][1], d[j][1]);
				a[i][j] = a[j][i] = s;
			}
		}
		for (int k = 1; k <= n; k++)
			for (int i = 1; i <= n; i++)
				for (int j = 1; j <= n; j++)
					if (a[i][j] > max(a[i][k], a[k][j]))
						a[i][j] = max(a[i][k], a[k][j]);
		printf("Scenario #%d\n", v++);
		printf("Frog Distance = %.3f\n\n", a[1][2]);
	}
	return 0;
}


易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!