【递推】Fibonacci Again

别等时光非礼了梦想. 提交于 2020-01-24 12:59:40

描述

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

输入

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

输出

Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

样例输入

0
1
2
3
4
5

样例输出

no
no
yes
no
no
no

题目来源

HDOJ
分析:斐波那契递推。
代码:
#include<bits/stdc++.h>
using namespace std;
int f[1000001];
void Fibo()
{
f[0]=7;f[1]=11;
for (int i=2;i<1000001;i++)
f[i]=(f[i-1]+f[i-2])%3;
}
int main()
{
Fibo();
int n;
while(cin>>n)
{
if (f[n]%3==0)
cout<<“yes”<<endl;
else
cout<<“no”<<endl;
}
return 0;
}

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!