PTA L1-062 幸运彩票 (15分)

霸气de小男生 提交于 2020-01-22 09:56:22

题目描述:

彩票的号码有 6 位数字,若一张彩票的前 3 位上的数之和等于后 3 位上的数之和,则称这张彩票是幸运的。本题就请你判断给定的彩票是不是幸运的。

输入格式:

输入在第一行中给出一个正整数 N(≤ 100)。随后 N 行,每行给出一张彩票的 6 位数字。

输出格式:

对每张彩票,如果它是幸运的,就在一行中输出 You are lucky!;否则输出 Wish you good luck.

输入样例:

2
233008
123456

输出样例:

You are lucky!
Wish you good luck.

解题报告:

1:判断,输出。

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main(){
    ll t;
    char ss[10];
    scanf("%lld", &t);
    while(t--){
        scanf("%s", ss);
        if(ss[0]+ss[1]+ss[2] == ss[3]+ss[4]+ss[5])printf("You are lucky!\n");
        else printf("Wish you good luck.\n");
    }
    return 0;
}


 

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!