图1是一个城堡的地形图。
请你编写一个程序,计算城堡一共有多少房间,最大的房间有多大。
城堡被分割成 m∗n个方格区域,每个方格区域可以有0~4面墙。
输入格式
第一行包含两个整数 m 和 n,分别表示城堡南北方向的长度和东西方向的长度。
接下来 m 行,每行包含 n 个整数,每个整数都表示平面图对应位置的方块的墙的特征。
每个方块中墙的特征由数字 P 来描述,我们用1表示西墙,2表示北墙,4表示东墙,8表示南墙,P 为该方块包含墙的数字之和。
例如,如果一个方块的 P 为3,则 3 = 1 + 2,该方块包含西墙和北墙。
城堡的内墙被计算两次,方块(1,1)的南墙同时也是方块(2,1)的北墙。
输入的数据保证城堡至少有两个房间。
输出格式
共两行,第一行输出房间总数,第二行输出最大房间的面积(方块数)。
数据范围
1≤m,n≤50,
0≤P≤15
输入样例:
4 7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13
输出样例:
5
9
这个处理墙的方法很特别,用二进制处理墙,并且和方向对应起来就可以了。
#include <iostream>
#include <cstdio>
using namespace std;
const int N = 60;
int n, m, area;
int a[N][N];
bool f[N][N];
int dx[] = {0, 1, 0, -1};
int dy[] = {1, 0, -1, 0};
void dfs(int x, int y) {
f[x][y] = 1;
area ++;
for(int i=0; i<4; i++) {
int tx = x + dx[i];
int ty = y + dy[i];
if(tx<0 || ty<0 || tx>=n || ty>=m) continue;
if(f[tx][ty]) continue;
if(a[tx][ty] >> i & 1) continue;
dfs(tx, ty);
}
}
int main() {
cin >> n >> m;
for(int i=0; i<n; i++) {
for(int j=0; j<m; j++) {
cin >> a[i][j];
}
}
int ans = 0, cnt = 0;
for(int i=0; i<n; i++) {
for(int j=0; j<m; j++) {
area = 0;
if(!f[i][j]) {
dfs(i, j);
cnt ++;
}
ans = max(ans, area);
}
}
cout << cnt << '\n' << ans;
return 0;
}
来源:CSDN
作者:行走天涯的豆沙包
链接:https://blog.csdn.net/weixin_42979819/article/details/104022172