题目描述
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
解题思路
一开始做这道题时,直接用的笨办法,没有去找规律,后来才知道这道题是有规律的,其实只要满足n除以4余2这个条件,就是yes,否则,就是no。
AC代码
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n%4==2)
{
cout<<"yes"<<endl;
}
else
{
cout<<"no"<<endl;
}
}
return 0;
}
来源:CSDN
作者:虐猫人薛定谔i
链接:https://blog.csdn.net/Deep___Learning/article/details/103995320