题目
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
解题思路
要建几条路使得任意两个城镇直接或间接相通,就是求连通块的数量减一。求连通块的数量的方法有搜索,并查集。
以下代码用并查集的方法找连通块。
代码
#include <cstdio>
using namespace std;
int father[1010];
int getfather(int x)
{
if (father[x]==x) return x;
father[x]=getfather(father[x]);
return father[x];
}
int main()
{
int n;
while (true)
{
scanf("%d",&n);
if (n==0) break;
int ans=0,m;
for (int i=1;i<=n;i++)
father[i]=i;
scanf("%d",&m);
for (int i=1;i<=m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
int aa=getfather(a);
int bb=getfather(b);
if (aa!=bb) father[aa]=bb;
}
for (int i=1;i<=n;i++)
if (father[i]==i) ans++;
printf("%d\n",ans-1);
}
}
题目
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
解题思路
先算出任意两个岛建桥的距离,如果距离满足条件,再算建桥的花费。然后题目要求建桥,使得任意两个岛之间直接或间接相通,求最小花费。这也是最小生成树问题,只要最后能选的边数量小于n-1,则说明这项工程不能实现(一棵n个节点的树有n-1条边)
代码
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int father[10101];
struct wahaha
{
int x,y;
double v;
}a[1010],c[10101];
int n,m;
int get_father(int x)
{
if (father[x]==x) return x;
father[x]=get_father(father[x]);
return father[x];
}
bool cmp(wahaha x,wahaha y)
{
return (x.v<y.v);
}
int main()
{
int T;
scanf("%d",&T);
while (T--)
{
scanf("%d",&n);
for (int i=1;i<=n;i++)
scanf("%d%d",&a[i].x,&a[i].y);
for (int i=1;i<=n;i++) father[i]=i;
memset(c,0,sizeof(c));
m=0;
for (int i=1;i<=n;i++)
for (int j=i+1;j<=n;j++)
{
double x=(a[i].x-a[j].x);
double y=(a[i].y-a[j].y);
double s=sqrt(x*x+y*y)*100;
if (x*x+y*y>=100 && x*x+y*y<=1000000)
{
m++;
c[m].x=i;
c[m].y=j;
c[m].v=s;
}
}
sort(c+1,c+m+1,cmp);
int num=0;
double ans=0;
for (int i=1;i<=m;i++)
{
int xx=get_father(c[i].x);
int yy=get_father(c[i].y);
if (xx==yy) continue;
father[xx]=yy;
num++;
ans+=c[i].v;
}
if (num!=n-1) printf("oh!\n");
else printf("%.1f\n",ans);
}
}
来源:CSDN
作者:水墨青杉
链接:https://blog.csdn.net/weixin_45723759/article/details/103996246