H - Horror Film Night Kattis - horrorfilmnight

☆樱花仙子☆ 提交于 2020-01-13 15:37:37

H - Horror Film Night

题意:有两个人想去一起看电影,然后分别给出两个人 分别喜欢看的电影都在哪些天,然后, 同一个人 不能连续看两天他不喜欢的电影。
求他们最多可以看多少次电影。

思路:把这两个人喜欢的电影分别标记一下,遍历1e7,
1.如果他们都喜欢,加一;2. 有一个喜欢而且上一场电影自己不喜欢的,加一。

Emma and Marcos are two friends who love horror films. This year, and possibly the years hereafter, they want to watch as many films together as possible. Unfortunately, they do not exactly have the same taste in films. So, inevitably, every now and then either Emma or Marcos has to watch a film she or he dislikes. When neither of them likes a film, they will not watch it. To make things fair they thought of the following rule: They can not watch two films in a row which are disliked by the same person. In other words, if one of them does not like the current film, then they are reassured they will like the next one. They open the TV guide and mark their preferred films. They only receive one channel which shows one film per day. Luckily, the TV guide has already been determined for the next 1 million days.

Can you determine the maximal number of films they can watch in a fair way?

Input
The input consists of two lines, one for each person. Each of these lines is of the following form:

One integer 0≤k≤1000000 for the number of films this person likes;

followed by k integers indicating all days (numbered by 0,…,999999) with a film this person likes.

Output
Output a single line containing a single integer, the maximal number of films they can watch together in a fair way.

Sample Input 1 Sample Output 1
1 40
2 37 42
3
Sample Input 2 Sample Output 2
1 1
3 1 3 2
2
Sample Input 3 Sample Output 3
1 2
1 2
1

#include<bits/stdc++.h>
using namespace std;
#define mm 10000010
int a[mm], b[mm];

int main()
{
    ios::sync_with_stdio(0);
    int n, m;
    cin >> n;
    memset(a, 0, sizeof(a));
    for(int i = 0; i <n; i ++)
    {
        int x;
        cin >>x;
        a[x] = 1;
    }
    cin >> m;
    memset(b, 0, sizeof(b));
    for(int i = 0; i < m; i ++)
    {
        int x;
        cin >> x;
        b[x] = 1;
    }
    int pre1 = 0;
    int pre2 = 0;
    int ans = 0;
    for(int i = 0; i < mm; i ++)
    {
        if(a[i]&&b[i])
        {
            pre1 = 0;
            pre2 = 0;
            ans++;
        }
        else if(a[i]&&!pre1)
        {
            pre2 = 0;
            pre1 = 1;
            ans++;
        }
        else if(b[i]&&!pre2)
        {
            pre2 = 1;
            pre1 = 0;
            ans++;
        }
    }
    cout << ans << endl;
    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!