Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
Sample Input
2 3
Sample Output
1
1 1
1
1 1
1 2 1
#include <stdio.h>
int main() {
int n,i,j;
int a[30][30];
while(~scanf("%d",&n)){
a[0][0] = 1;
a[0][1] = 0;
if(n == 1){
printf("%d\n",a[0][0]);
}
else{
printf("%d\n",a[0][0]);
for(i = 1; i < n; i++){
for(j = 0; j <= i; j++){
if(j == 0 || j == i){ //第一个和最后一个都是1
a[i][j] = 1;
}
else{ //其余的等于上一行的左边一个加右边一个
a[i][j] = a[i-1][j-1] + a[i-1][j];
}
if(j > 0){
printf(" ");
}
printf("%d",a[i][j]);
}
printf("\n");
}
}
printf("\n");
}
return -1;
}
来源:CSDN
作者:CreatorZhou
链接:https://blog.csdn.net/im_rookie/article/details/103757689