HDU 1004 Let the Balloon Rise

风格不统一 提交于 2019-12-27 17:44:42

Problem Description

Contest timeagain! How excited it is to see balloons floating around. But to tell you asecret, the judges' favorite time is guessing the most popular problem. Whenthe contest is over, they will count the balloons of each color and find theresult.

This year, they decide to leave this lovely job to you. 

Input

Inputcontains multiple test cases. Each test case starts with a number N (0 < N<= 1000) -- the total number of balloons distributed. The next N linescontain one color each. The color of a balloon is a string of up to 15lower-case letters.

A test case with N = 0 terminates the input and this test case is not to beprocessed. 

Output

For eachcase, print the color of balloon for the most popular problem on a single line.It is guaranteed that there is a unique solution for each test case. 

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

Sample Output

red

pink


#include <iostream>

#include <string>

using namespace std;

int main()

{

   int N;

   while(cin>>N&&N!=0)

    {

       string str[1000],temp;

       int a[1000]={0};

       int i,j,k=0;

       cin>>str[0];

       a[0]=1;

       for(i=1;i<N;i++)

       {

           cin>>temp;

           bool flag=false;

           for(j=0;j<=k;j++)

                if(temp==str[j])

                    {

                        a[j]++;

                        flag=true;

                    }

           if(!flag)

           {

                str[++k]=temp;

                a[k]=1;

           }

       }

        int max=a[0],mark1=0;

       for(i=0;i<=k;i++)

           if(max<a[i])

          {

           max=a[i];

           mark1=i;

          }

       cout<<str[mark1]<<endl;

    }

   return 0;

}

标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!