Fliptile POJ - 3279

喜你入骨 提交于 2019-11-26 19:56:33

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

#include<iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <queue>
#define read(x) scanf("%d",&x)
using namespace std;
int n,k,m=0;
const int N=1e1+7;

int a[N][N],t[N][N];
int dx[5]={0,0,1,-1,0};
int dy[5]={1,-1,0,0,0};
bool ok;
bool inedge(int x,int y)
{
    return x>=0&&x<n&&y>=0&&y<m;
}
void change(int x,int y)
{
    for(int j=0;j<5;j++){
        if(inedge(x+dx[j],y+dy[j]))
            a[x+dx[j]][y+dy[j]]^=1;
    }
}
void dfs(int x)
{
    if(ok) return;
    if(x==n){
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(a[i][j]) return ;
        ok=true;
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                printf("%d%c",t[i][j],j==m-1?'\n':' ');
        return;
    }
    int p[N],tot=0;
    for(int i=0;i<m;i++){
        if(a[x-1][i]){
            t[x][i]=1;
            change(x,i);
            p[tot++]=i;
        }
    }
    dfs(x+1);
    for(int i=0;i<tot;i++){
        change(x,p[i]);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                read(a[i][j]);
        ok=false;
        for(int i=0;i<(1<<m)&&!ok;i++){
            memset(t,0,sizeof(t));
            for(int j=0;j<m;j++){
                if(i&(1<<j)){
                    change(0,j);
                    t[0][j]=1;
                }
            }
            dfs(1);
            for(int j=0;j<m;j++){
                if(i&(1<<j)){
                    change(0,j);
                }
            }
        }
        if(!ok) puts("IMPOSSIBLE");
    }

    return 0;
}
标签
易学教程内所有资源均来自网络或用户发布的内容,如有违反法律规定的内容欢迎反馈
该文章没有解决你所遇到的问题?点击提问,说说你的问题,让更多的人一起探讨吧!