eval

蓝桥杯 基础练习 矩形面积交 Python

霸气de小男生 提交于 2020-01-29 04:14:03
平面上有两个矩形,它们的边平行于直角坐标系的X轴或Y轴。对于每个矩形,我们给出它的一对相对顶点的坐标,请你编程算出两个矩形的交的面积。 输入格式: 在每行中,给出矩形的一对相对顶点的坐标,每个点的坐标都用两个绝对值不超过10^7的实数表示。 输出格式: 请在这里描述输出格式。例如:对每一组输入,在一行中输出A+B的值。 输入样例: 输出仅包含一个实数,为交的面积,保留到小数后两位。 1 1 3 3 2 2 4 4 输出样例: 在这里给出相应的输出。例如: 1.00 思路: 先把两个矩形的坐标都变成从左下角的到右上角的顺序然后判断是否这两个矩形不重合 然后将所有的横坐标x排序,取中间两个的差值为重合面积的一条边的长度然后将所有的纵坐标y排序,取中间两个的差值为重合面积的另一条边的长度~然后得重合面积的值 代码: s1 = input ( ) . split ( ) s2 = input ( ) . split ( ) d1 = [ eval ( s1 [ 0 ] ) , eval ( s1 [ 2 ] ) ] d2 = [ eval ( s1 [ 1 ] ) , eval ( s1 [ 3 ] ) ] d3 = [ eval ( s2 [ 0 ] ) , eval ( s2 [ 2 ] ) ] d4 = [ eval ( s2 [ 1 ] ) , eval ( s2 [ 3 ] )

webpack的devtool

佐手、 提交于 2020-01-29 03:41:18
这里以环境分类为分析方向 1.对开发环境 eval - 每个模块都使用 eval() 执行,并且都有 //@ sourceURL 。此选项会非常快地构建。主要缺点是,由于会映射到转换后的代码,而不是映射到原始代码(没有从 loader 中获取 source map),所以不能正确的显示行数。 eval-source-map - 每个模块使用 eval() 执行,并且 source map 转换为 DataUrl 后添加到 eval() 中。初始化 source map 时比较慢,但是会在重新构建时提供比较快的速度,并且 生成实际的文件 。行数能够正确映射,因为会映射到原始代码中。它会生成用于开发环境的最佳品质的 source map。 cheap-eval-source-map - 类似 eval-source-map ,每个模块使用 eval() 执行。这是 "cheap(低开销)" 的 source map,因为它 没有生成列映射 (column mapping),只是 映射行数 。它会忽略源自 loader 的 source map,并且仅显示转译后的代码,就像 eval devtool。 cheap-module-eval-source-map - 类似 cheap-eval-source-map ,并且,在这种情况下,源自 loader 的 source map

Python常用内置函数

一世执手 提交于 2020-01-28 19:31:39
目录 compile() eval() filter() map() range() zip() reduce() 例子 compile() # compile()_39 """ compile() compile(source, filename, mode[, flags[, dont_inherit]]) compile() 函数将一个字符串编译为字节代码。 source -- 字符串或者AST(Abstract Syntax Trees)对象。。 filename -- 代码文件名称,如果不是从文件读取代码则传递一些可辨认的值。 mode -- 指定编译代码的种类。可以指定为 exec, eval。 flags -- 变量作用域,局部命名空间,如果被提供,可以是任何映射对象。。 flags和dont_inherit是用来控制编译源码时的标志 """ # 将语句转换为字节码文件,exec() 函数能运行该字节码文件 var0 = compile ( 'print("I Love You.")' , '' , 'exec' ) # <code object <module> at 0x03420548, file "", line 1> exec ( var0 ) # I Love You. # 将该字符串转换为字节码文件,eval() 函数能将该字节码文件的结果计算出来

把GridView列设为链接

风流意气都作罢 提交于 2020-01-25 23:48:04
<asp:GridView ID="GridView1" runat="server" Width="100%" AutoGenerateColumns="False" OnPageIndexChanging="GridView1_PageIndexChanging" AllowPaging="True" OnRowDataBound="GridView1_RowDataBound" DataKeyNames="mailid" BorderColor="Black"> <Columns> <asp:TemplateField HeaderText="栏目名称"> <ItemTemplate> <a href="Send_read.aspx?MailID=<%# Eval("MailID")%>" class="time"><%# Eval("ZhuTi")%></a> </ItemTemplate> <EditItemTemplate> <asp:TextBox ID="name_chaolianjie" runat="server" Text='<%# Eval("ZhuTi") %>'></asp:TextBox> </EditItemTemplate> <ItemStyle HorizontalAlign="Center" /> </asp:TemplateField> 其中

Generating evalable python code: all combinations of functions in disjunctive normal form

|▌冷眼眸甩不掉的悲伤 提交于 2020-01-24 09:39:25
问题 (A,B,C) = (100, 200, 300) def f1(p): return p+50 def f2(p): return p*1.5 def f3(p): return p*p vars_ = (A,B,C) funcs_ = [f1, f2, f3] logic_ = ["and","or"] vol_lmt_ = [200, 300] op_ = [">","<","="] I want generate the assert code string for eval() to test the validity, take below one for example: "f1(A)>200 and f1(B)>200 and f1(C)>200" # True -^-------------^-------------^------------: funcs_ ----^-------------^-------------^---------: vars_ ------^-------------^-------------^-------: op_ ----

Calling a function by a string in JavaScript and staying in scope

≡放荡痞女 提交于 2020-01-24 01:22:29
问题 I've been playing around and searching a bit, but I can't figure this out. I have a pseudo private function within a JavaScript object that needs to get called via eval (because the name of the function is built dynamically). However, the function is hidden from the global scope by a closure and I cannot figure out how to reference it using eval(). Ex: var myObject = function(){ var privateFunctionNeedsToBeCalled = function() { alert('gets here'); }; return { publicFunction: function

python内置函数

[亡魂溺海] 提交于 2020-01-23 14:27:23
1.abs()获取绝对值 >>> abs(-10) 10 >>> a = -10 >>> a.__abs__() 10 2. all() 参数为可迭代对象,迭代对象为空时,返回True.如果迭代对象的所有元素都为真,那么返回True,否则返回False. all(['python',123]) --->True all([]) --->True all([0]) --->False all(" ") --->True all(1,' ',2,None) --->False 3.any() 参数为可迭代对象,参数为空时返回True print(any([None,0,' ',{},1])) --->True print(any(' ')) --->True 4.sum() 求和 >>> res = sum(i for i in range(5)) >>> print(res) 10 5.bin() 将参数转化为二进制 >>> bin(3) '0b11' >>> bin(10) '0b1010' 6.bool() 布尔函数,返回bool值,False或True >>> bool(3) True >>> bool(0) False >>> bool(None) False 7. ascii()  调用对象的__repr__()方法,获得该方法的返回值 8.bytes()

alpha-belta 剪枝实现棋类AI ——Tic-Tac-Toe

纵然是瞬间 提交于 2020-01-23 01:25:49
文章目录 定义抽象类 棋子 Piece、棋盘 Board 继承抽象类 AI 算法 minimax alpha-beta 剪枝 基于 ab剪枝 寻找最优策略 来一局! python 版本 3.7 喔! 定义抽象类 棋子 Piece、棋盘 Board from __future__ import annotations from typing import NewType , List from abc import ABC , abstractmethod Move = NewType ( 'Move' , int ) class Piece : @ property def opposite ( self ) - > Piece : raise NotImplementedError ( "Should be implemented by subclasses." ) class Board ( ABC ) : @ property @abstractmethod def turn ( self ) - > Piece : . . . @abstractmethod def move ( self , location : Move ) - > Board : . . . @ property @abstractmethod def legal_moves ( self ) - >

python基础练习3

烈酒焚心 提交于 2020-01-22 23:58:45
1. 从键盘上输⼊⼀个数,显示它的绝对值(不允许使⽤abs)。 答案: num = int ( input ( "请输入一个数字:" ) ) if num > 0 : print ( "%d的绝对值为%d" % ( num , num ) ) else : print ( "%d的绝对值为%d" % ( num , - num ) ) 2. 假设⽤户名为admin,密码为123abc,从控制台分别输⼊⽤户名和密码,如果和已知⽤户名和密码都匹配上的话,则验证成功,否则验证失败。 答案: user = input ( "请输入用户名:" ) password = input ( "请输入密码:" ) if user == "admin" and password == "123abc" : print ( "验证成功" ) else : print ( "验证失败" ) 3. 计算⾯积 编写程序,由⽤户输⼊的三⻆形的三条边,计算三⻆形的⾯积。 答案: import math a , b , c = eval ( input ( "请分别输入三角形的三个边长,用逗号分隔:" ) ) if a + b < c or a + c < b or b + c < a : print ( "无法构成三角形" ) else : L = ( a + b + c ) / 2 s = math .

Dynamic scoping questions in R

和自甴很熟 提交于 2020-01-22 15:08:45
问题 I'm reading the AdvancedR by Hadley and am testing the following code on this URL subset2 = function(df, condition){ condition_call = eval(substitute(condition),df ) df[condition_call,] } df = data.frame(a = 1:10, b = 2:11) condition = 3 subset2(df, a < condition) Then I got the following error message: Error in eval(substitute(condition), df) : object 'a' not found I read the explanation as follows but don't quite understand: If eval() can’t find the variable inside the data frame (its