Does OS X have an equivalent to /dev/shm?

后端 未结 1 1250
时光说笑
时光说笑 2021-01-30 02:43

Does OS X (Snow Leopard in particular) have an equivalent to (some versions of) Linux\'s /dev/shm , ie something where you can write to and read from a file without

相关标签:
1条回答
  • 2021-01-30 03:05

    You can create and mount a ram based disk as follows:

    1. Create a disk

      hdiutil attach -nomount ram://$((2 * 1024 * SIZE_IN_MB))
      

      hdiutil will return the name of the ramdisk.

    2. Format and mount the disk

      diskutil eraseVolume HFS+ RAMDisk NAME_OF_DISK
      
    3. Access the disk under /Volumes/<diskname>

      cd /Volumes/RAMDisk && touch testfile.txt && ls
      

    Creating a 100MB ramdisk:

    $ hdiutil attach -nomount ram://$((2 * 1024 * 100))
    /dev/disk3
    
    $ diskutil eraseVolume HFS+ RAMDisk /dev/disk3
    Started erase on disk3
    Unmounting disk
    Erasing
    Initialized /dev/rdisk3 as a 100 MB case-insensitive HFS Plus volume
    Mounting disk
    Finished erase on disk3 RAMDisk
    

    Original source: http://www.frederico-araujo.com/2008/12/18/blazing-fast-firefox-using-osx-ramdisk/

    0 讨论(0)
提交回复
热议问题