This is what I would like to do:
{ ... if(condition) break; ... }
This works for a loop. I would like something similar
How about
do { ... if(condition) break; ... } while (0);
I don't particularly like this style but I've seen it before. If refactoring is out of the question (could be for a massive block that can break a lot of stuff if changed), this is an option.