Is using underscore suffix for members beneficial?

后端 未结 13 2059
猫巷女王i
猫巷女王i 2020-12-29 03:58
class C {
 private:
  int member_; // here is the underscore I refer to.
}

This underscore is recommended by Google Style Guide and Geosoft\'s C++

相关标签:
13条回答
  • 2020-12-29 04:38

    I always want to distinguish the class members from the variables. I use the _ as prefix for members and personally speaking this keeps the code clean and readable. Prefixes work fine with the editor's intellisense. Prefixing with m_ or s_ is useful but It looks ugly to me.

    0 讨论(0)
  • 2020-12-29 04:43

    there is one more "style" which suggests declaring class members as below:

    class Foo{
        int m_value;
    public:
         //...
    };
    

    i found it usable. but it is just my point of view.

    0 讨论(0)
  • 2020-12-29 04:45

    This is basically a religious argument so you're never going to reach a consensus on this style. FWIW, I use this style for my member variables for reasons already stated by others, e.g.:

    class Foo
    {
    public:
      Foo(std::string name, int age) :
        name_(name),
        age_(age)
      {
      }
    
      std::string name() const { return name_; }
      void name(const std::string& name) { name_ = name; }
    
      int age() const { return age_; }
      void age(int age) { age_ = age; }
    private:
      std::string name_;
      int age_;
    };
    

    Just adopt something you're happy with and stick with it.

    0 讨论(0)
  • 2020-12-29 04:47

    I agree with Tobias that there's a benefit to some convention -- whatever it may be -- to highlighting class variables. On the other hand, I invariably find that such conventions make the code "flow" less well. It's just easier to read "totalPrice = productPrice + salesTax" then "m_totalPrice = l_productPrice + l_salesTax" or whatever.

    In the end, I prefer to just leave all the field names undecorated, and have few enough class variables that keeping track of them is not a problem. In constructors and setters, I put a prefix or suffix on the parameter, or in Java I typically distinguish the class variable with "this.", like:

    public Foo(int bar)
    {
      this.bar=bar;
    }
    

    (Can you do that in C++? It's been so long I don't remember.)

    0 讨论(0)
  • 2020-12-29 04:48

    This came up in discussion we had where I work but with Java programming. But I think this applies to C++ as well. My answer is that IDE's have a handy function of coloring class member variables. In Eclipse they turn blue. The underscore is superfluous. As another poster put it, "EW, hungarian warts!!". 1980 called and wants it's hungarian notation back.

    0 讨论(0)
  • 2020-12-29 04:50

    Well since no one mentioned it: adding an underscore to member variable allows you to name your getter and setter with the 'conceptual' name of the variable.

    ex:

    class MyClass
    {
       int someMember_;
    
    public:
       int someMember() const { return someMember_; }
       void someMember( int newValue ) { someMember_ = newValue; }
    };
    

    not that I use this style though.

    0 讨论(0)
提交回复
热议问题