More fluent C# / .NET

后端 未结 21 1181
名媛妹妹
名媛妹妹 2020-12-23 22:51

A co-worker of mine came up with this and I wonder what others think? Personally, I find it interesting but wonder if it is too big a departure? Code examples below. Extensi

相关标签:
21条回答
  • 2020-12-23 23:46

    I guess I fail to see what the new versions get you. The original is pretty clear and is less wordy. I would guess that it would be faster as well. I would avoid using (abusing?) language features like this unless there is a clear benefit.

    0 讨论(0)
  • 2020-12-23 23:46

    My 2 cents: It looks fine, my only comment is that "With" kind of implies something like "Where" or "Having" when you are actually setting a property. I'd suggest a method name of something like "Do", "Execute" or "Set" but maybe thats just my odd world view.

    How about:

    Page.WithControl<DropDownList>("LocationDropDownList")
        .Do(d => d.Visible = true)
        .Do(d => d.SelectedValue = "123")
        .DoIf(isAdmin, d => d.Items.Add(new ListItem("Admin", "1")));
    
    0 讨论(0)
  • 2020-12-23 23:46

    Good rule of thumb:

    If your first impression of your code is "This is clever" - it's probably not a good idea.

    Good code should be simple, readable, and only "clever" if absolutely necessary.

    0 讨论(0)
  • 2020-12-23 23:48

    Minor note. From personal experience, I'd change:

    if(isAdmin)
        ddl.SelectedValue = "111";
    

    to

    if(isAdmin) {
        ddl.SelectedValue = "111";
    }
    

    or

    if(isAdmin) 
    {
        ddl.SelectedValue = "111";
    }
    

    This will save you time in debugging sooner or later.

    0 讨论(0)
  • 2020-12-23 23:53

    One more vote for "not useful". The With extension method doesn't do anything except wrap up sequenced statements with a method. C# already already has a built-in function for sequencing statements, its called ;.

    Similarly, the WithIf wraps an if-statement without any modification to the control flow. From my point of view, you're only inviting yourself to methods like:

    public static T For<T>(
        this T t, int start, Func<int, bool> cond, Action<T, int> f)
    {
        for(int i = start; cond(i); i++)
        {
            f(t, i);
        }
        return t;
    }
    
    0 讨论(0)
  • 2020-12-23 23:54

    Regarding a "Fluent Interface" C# already has a great syntax for initializers which is (IMHO) better that trying to use the fluent style. Of course, in your example you are not initializing an new object, you are changing an existing one. My whole expertise with Fluent interfaces comes from a 30 second scan of wikipedia, but I think that JeeBee's answer is more in the spirit of Fluent programming, though I might change things slightly:

    Page.FindDropDownList("LocationDropDownList")    
      .setVisible(true)    
      .setAdminSelectedValue("111")
      .setSelectedValue("123")
    

    One could argue that this is more readable, especially for a language without Properties, but I still think it doesn't make sense in C#.

    0 讨论(0)
提交回复
热议问题