How to uninstall Jenkins?

前端 未结 8 1267
谎友^
谎友^ 2020-12-22 14:45

This is probably very simple, but I can\'t find any hint anywhere. So how one is supposed to do that, in general and specifically on Mac?

相关标签:
8条回答
  • 2020-12-22 15:38

    Run the following commands to completely uninstall Jenkins from MacOS Sierra. You don't need to change anything, just run these commands.

    sudo launchctl unload /Library/LaunchDaemons/org.jenkins-ci.plist
    sudo rm /Library/LaunchDaemons/org.jenkins-ci.plist
    sudo rm -rf /Applications/Jenkins '/Library/Application Support/Jenkins' /Library/Documentation/Jenkins
    sudo rm -rf /Users/Shared/Jenkins
    sudo rm -rf /var/log/jenkins
    sudo rm -f /etc/newsyslog.d/jenkins.conf
    sudo dscl . -delete /Users/jenkins
    sudo dscl . -delete /Groups/jenkins
    pkgutil --pkgs
    grep 'org\.jenkins-ci\.'
    xargs -n 1 sudo pkgutil --forget
    

    Salam

    Shah

    0 讨论(0)
  • 2020-12-22 15:42

    These instructions apply if you installed using the official Jenkins Mac installer from http://jenkins-ci.org/

    Execute uninstall script from terminal:

    '/Library/Application Support/Jenkins/Uninstall.command'
    

    or use Finder to navigate into that folder and double-click on Uninstall.command.

    Finally delete last configuration bits which might have been forgotten:

    sudo rm -rf /var/root/.jenkins ~/.jenkins
    

    If the uninstallation script cannot be found (older Jenkins version), use following commands:

    sudo launchctl unload /Library/LaunchDaemons/org.jenkins-ci.plist
    sudo rm /Library/LaunchDaemons/org.jenkins-ci.plist
    sudo rm -rf /Applications/Jenkins "/Library/Application Support/Jenkins" /Library/Documentation/Jenkins
    

    and if you want to get rid of all the jobs and builds:

    sudo rm -rf /Users/Shared/Jenkins
    

    and to delete the jenkins user and group (if you chose to use them):

    sudo dscl . -delete /Users/jenkins
    sudo dscl . -delete /Groups/jenkins
    

    These commands are also invoked by the uninstall script in newer Jenkins versions, and should be executed too:

    sudo rm -f /etc/newsyslog.d/jenkins.conf
    pkgutil --pkgs | grep 'org\.jenkins-ci\.' | xargs -n 1 sudo pkgutil --forget
    
    0 讨论(0)
提交回复
热议问题