In my controller I have two actions called \"Friends\". The one that executes depends on whether or not it\'s a \"get\" versus a \"post\".
So my code snippets look s
Rename the second method to something else like "Friends_Post" and then you can add [ActionName("Friends")]
attribute to the second one. So the requests to the Friend action with POST as request type, will be handled by that action.
// Get:
[AcceptVerbs(HttpVerbs.Get)]
public ActionResult Friends()
{
// do some stuff
return View();
}
// Post:
[ActionName("Friends")]
[AcceptVerbs(HttpVerbs.Post)]
public ActionResult Friends_Post()
{
// do some stuff
return View();
}
add to the Post method the params to want to receive in the post. maybe like this:
// Post:
[AcceptVerbs(HttpVerbs.Post)]
public ActionResult Friends(string friendName, string otherField)
{
// do some stuff
return View();
}
..or if you have a complex type, like this:
// Post:
[AcceptVerbs(HttpVerbs.Post)]
public ActionResult Friends(Friend friend)
{
// do some stuff
return View();
}
Edit: It would be preferable to use a more typed-approach to receiving the posted items, like above.
If you truly only want one routine to handle both verbs, try this:
[AcceptVerbs("Get", "Post")]
public ActionResult ActionName(string param1, ...)
{
//Fun stuff goes here.
}
One potential caveat: I'm using MVC release 2. Not sure if this was supported in MVC 1. The Intellisense documentation for AcceptVerbs should let you know.
not entirely sure if it is the correct way, but i would use a meaningless parameter to differentiate the sigs. like:
// Get:
[AcceptVerbs(HttpVerbs.Get)]
public ActionResult Friends(bool isGet)
{
// do some stuff
return View();
}
// Post:
[AcceptVerbs(HttpVerbs.Post)]
public ActionResult Friends()
{
// do some stuff
return View();
}
I know it's ugly and hackish, but it works.
Try using:
[AcceptVerbs(HttpVerbs.Post | HttpVerbs.Get)]
public ActionResult Friends()
{
// do some stuff
return View();
}
Your action methods can't be doing the same thing, otherwise there would be no need to to write two action methods. So if the semantics are different, why not use different names for the action methods as well?
For example, if you had a "delete" action method and GET just asks for confirmation, you might call the GET method "ConfirmDelete" and the POST method just "Delete".
Not sure if that matches your scenario, but it always did for me when I had the same problem.