I think Lasse V. Karlsen has the right of it in his comments, a redesign is more appropriate perhaps
You could create an interface like Stecya suggests
public interface IUriAccessible { //or some sort of a more descriptive name
Uri Url {get;}
}
and then for each object that you care for, eg Entry
, you could
public class Entry:IUriAccessible {
//... other code here
public Uri Url {
get {
//return uri here
}
}
}
and now you can just call it on the object
var entry = new Entry();
var uri = entry.Url;